Category: MacOSX

Install RabbitMQ on Mojave

Overview For the installation we will use homebrew which is popular package manager for MacOS. Installation Make sure the taps are up-to-date before installing: $ brew update Then install its package: $ brew install rabbitmq Add rabbitmq executable path to environment variable: $ export PATH=$PATH:/usr/local/opt/rabbitmq/sbinĀ   

Error: “checking for my_bool in mysql.h… no” While Installing MySQL2 Gem on Mojave

The necessary header files location for compiling C extensions had changed on Mojave. You need to run the following command to install mysql2, pg, nokogiri, or other gems that require C extensions : $ sudo installer -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg -target / Then install mysql2 gem : $ gem install mysql2 — –with-mysql-config=/usr/local/Cellar/mysql/<mysql_version>/bin/mysql_config

Error while install mysql2 ruby gem

How to fix “An error occurred while installing mysql2 (*)” when install mysql2 ruby gem ? The solution is just run this command on your terminal : On Ubuntu : $ sudo apt-get install libmysqlclient-dev On Redhat / Centos / Fedora : $ sudo yum install mysql-devel On Mac OSX with Homebrew : $ brew […]

How To Fix can’t find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException)

If you got this error : $ bundle Traceback (most recent call last): 2: from /home/ubuntu-user/.rbenv/versions/2.5.1/bin/bundle:23:in `<main>’ 1: from /home/ubuntu-user/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems.rb:308:in `activate_bin_path’ /home/ubuntu-user/.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems.rb:289:in `find_spec_for_exe’: can’t find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException) when bundling your gem on your rails app, the solution to fix is easy. Just updating your gem system using this command […]

Install Ruby on Rails with Jemalloc on Mac Mojave

Install Ruby on Rails with Jemalloc on Mac Mojave First we need to Install Ruby via Homebrew : ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)” And then install dependency libraries : brew install rbenv gmp jemalloc ruby-build sqlite3 Add rbenv to bash profile : echo ‘if which rbenv > /dev/null; then eval “$(rbenv init -)”; fi’ >> […]

Scroll to Top