How To Fix Error “checking for libpq-fe.h… no” While Installing PG Gem on Ubuntu & Mac

To resolve this error on Ubuntu just run :

$ sudo apt-get install libpq-dev

And on Mac :

gem install pg -v '0.20.0' -- --with-pg-config=/Applications/Postgres.app/Contents/Versions/11/bin/pg_config

Just change the pg gem version and PostgreSQL version depending on your need.

Scroll to Top
%d bloggers like this: